Email Mailflow Issues

Incident Report for Trinity Logistics

Resolved

The mailflow issue has been resolved and email flow should be operating normally. Please submit a ticket if you continue to notice issues.
Posted Nov 24, 2025 - 11:36 EST

Identified

We are currently experiencing issues with email mailflow. Our team is actively investigating the situation to identify and resolve the root cause.
We will provide an update as soon as more information becomes available.
Posted Nov 24, 2025 - 10:23 EST
This incident affected: IT Operations (Email Services).