The incident has been resolved. If you are still experiencing issues, please contact your Service Team. We apologize for the inconvenience and thank you for your patience.
Posted Sep 09, 2026 - 11:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results. If you are still experiencing issues, please contact the ServiceDesk.
More updates to come and thank you for your patience.
Posted Sep 09, 2026 - 09:47 EDT
Investigating
We're aware that Dayforce login is currently running slow/lagging for some users.