Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 08, 2024 - 22:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 06, 2024 - 14:31 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 06, 2024 - 14:28 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 06, 2024 - 14:25 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 30, 2024 - 14:47 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 30, 2024 - 14:46 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Oct 30, 2024 - 14:27 EDT
Scheduled
What is happening? Technology Services team will be performing general maintenance to Trinity Systems. During the maintenance TMS and other services will not be available. Although we do not anticipate using the entire maintenance window, it may be needed to complete this work. For additional information, please contact us at help@trinitylogistics.com
When? Start Time: 10:00 PM EST End Time: 12:00 AM EST Expected Duration: 2 Hours
What systems are impacted? TMS, QE, Providers, Customer Portal, and Carrier Portal. *These systems should only be temporarily impacted during the maintenance window. What action must I take? No action is needed. This is a scheduled maintenance.
Posted Oct 25, 2024 - 15:13 EDT
This scheduled maintenance affected: Trinity TMS (Trinity TMS (Shipments, CRM, Providers, Cases)) and QE Module, Carrier Portal, Customer Portal.