Service Alert- RingCentral SMS

Incident Report for Trinity Logistics

Resolved



The incident has been resolved. If you are still experiencing issues, please contact your Service Team. We apologize for the inconvenience and thank you for your patience.
Posted Aug 31, 2026 - 16:45 EDT

Monitoring



A fix has been implemented and we are monitoring the results. If you are still experiencing issues, please contact your Service Team. More updates to come. Thank you for your patience.
Posted Aug 31, 2026 - 11:10 EDT

Investigating



RingCentral is currently experiencing technical difficulties affecting SMS services in parts of the Northern U.S. and Canada. At this time, the issue appears to be primarily impacting our Minnesota offices.

Outbound SMS messages are successfully sent; however, replies back to us may not be received.

RingCentral is actively working with regional carriers to identify and resolve the issue as quickly as possible.

If you are experiencing SMS issues and are located at an RSC location other than Minnesota, please submit a support ticket so we can provide RingCentral with additional details and assess the scope of the impact.

We will provide the updates on the Statuspage https://status.trinitylogistics.com/ and via email as they come in. Thank you for your patience.
Posted Aug 31, 2026 - 10:10 EDT
This incident affected: Phone System (SMS).