Service Alert - Delay in TMS Shipment Status Updates

Incident Report for Trinity Logistics

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 11:35 EDT

Monitoring



A fix has been implemented and we are monitoring the results. If you are still experiencing issues, please contact the ServiceDesk.

More updates to come and thank you for your patience.
Posted Mar 19, 2026 - 10:00 EDT

Identified



We have identified the cause of the issue and are working diligently to restore functionality of Shipment Statuses in the TMS.

This issue may also affect some reports in Power BI.

We apologize for the inconvenience and will share an update once we have more information.

More updates to come and thank you for your patience.
Posted Mar 19, 2026 - 09:30 EDT
This incident affected: Trinity TMS (Trinity TMS (Shipments, CRM, Providers, Cases)).